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Tworzenie oprogramowania 
dla ARM’ów pod Linuxem
Darmowe, zintegrowane środowisko 
programistyczne dla mikrokontrolerów ARM
Na internetowym forum EP, w dziale poświęconym dyskusjom i komentarzom na 
temat magazynu EP, jakiś czas temu pojawił się wątek w którym czytelnicy zasuge-
rowali, aby w jednym z wydań czasopisma pojawił się artykuł o programowaniu 
mikrokontrolerów pod Linuksem. Ponieważ to forum zostało stworzone, aby utwo-
rzyć pewnego rodzaju sprzężenie zwrotne celem lepszego, ciągłego dostosowywania 
EP do potrzeb czytelników, artykuł ten jest odpowiedzią na prośbę forumowiczów 
i przedstawia w jaki sposób zainstalować i skonfigurować zintegrowane środowisko 
programistyczne dla mikrokontrolerów  ARM pod systemem Linux.

tar zxvf eclipse-cpp-indigo-SR2-incubation-
linux-gtk-x86_64.tar.gz

W trybie graficznym w katalogu domowym tworzymy fol-
der development i przenosimy do niego folder eclipse. Używając 
konsoli wpisujemy:
mkdir ~/development
mv -f ~/Downloads/eclipse ~/development/

Typ sposobem Eclipse jest gotowy do pracy. Można go 
uruchamiać poprzez dwukrotne kliknięcie na ikonie eclipse lub 
w razie potrzeby z konsoli poprzez wpisanie komendy:
~/development/eclipse/eclipse

Używając konsoli, będąc już w folderze eclipse należy wpisać 
(na komputerze należy mieć zainstalowaną maszynę wirtualną Javy)

Sourcery CodeBench
W poprzednich artykułach opisujących zintegrowane śro-

dowisko programistyczne dla mikrokontrolerów ARM pod 
Windowsa, jako toolchain użyty został pakiet firmy CodeSo-
urcery – Sourcery G++ Lite Edition. Jednak w ubiegłym roku 
firma Mentor Graphics przejęła oprogramowanie CodeSourcery 
i  je rozwija pod inną nazwą: Sourcery CodeBench. Ponieważ 
nadal dostępna jest darmowa wersja tego toolchain’a, która do-
datkowo tworzona jest w wersji linuksowej, została ona użyta 
w opisywanym środowisku dla mikrokontrolerów ARM. W celu 
pobrania go, otwieramy stronę internetową www.mentor.com, 
a następnie wybieramy Products –> Embedded Software –> So-
urcery CodeBench. Na nowej stronie klikamy przycisk Editions 
i wybieramy darmową wersję oprogramowania „Sourcery Co-
deBench Lite Edition”. Z zestawienia znajdującego się na dole 
strony wybieramy „Download the EABI Release” dla proceso-
rów ARM. Tworzymy własne konto lub jeżeli już je posiadamy 
– logujemy się w serwisie. W mailu otrzymamy link do oprogra-
mowania. Na stronie klikamy na link „Download CodeBench 
Lite 2011.09-69” (lub nowszy, jeżeli będzie dostępny), a  na-
stępnie „IA32 GNU/Linux Installer” i zapisujemy go na dysku 
(domyślnie w folderze ~/Downloads). W chwili pisania artykułu 
jest to wersja Sourcery G++ Lite 2011.09-69 ważąca 108 MB). 
Pobrany plik jest w postaci binarnej. Będąc w  folderze ~/Do-
wnloads można go uruchomić z poziomu konsoli poleceniem:

W  numerach 2-3/2011 EP opublikowano artykuły 
przedstawiające instalację tytułowego środowiska dla 
systemu operacyjnego Windows. Jednak z  pewnych 
względów nie wszystkie dane oraz linki tam zawarte są 
nadal aktualne. Dodatkowo instalacja nowych aplikacji 
i środowisk bywa często kłopotliwa zarówno dla nowych 
jak i obytych z systemem Linux osób. Jednym z bodźców 
do napisania tego artykułu była chęć minimalizacji cza-
su jaki elektronik będzie musiał poświęcić na instalację 
opisanego pakietu.

Który Linux?
Dystrybucji Linuksa jest wiele. Nie można obiek-

tywnie stwierdzić, która jest najlepsza – każda ma swoje 
wady i zalety. Artykuł ten opisuje instalację i konfigura-
cję zintegrowanego środowiska do tworzenia oprogra-
mowania dla mikrokontrolerów ARM oraz jego wczyty-
wania i  debugowania w  Ubuntu 11.10 (64-bit). Jednak, 
aby nie ograniczać się tylko do jednej dystrybucji zostaną 
również podane komendy dzięki którym instalacja po-
szczególnych pakietów będzie możliwa poprzez konsolę. 
Dzięki temu artykuł może być bardziej pomocny osobom 
korzystającym z innych dystrybucji Linuxa.

Eclipse
Sprawdzonym i bardzo dobrze spisującym się pod Linuksem 

środowiskiem programistycznym jest Eclipse, który ma możli-
wość integracji z  innymi aplikacjami. Pobieramy go wchodząc 
na stronę internetową www.eclipse.org, następnie klikamy na za-
kładkę Downloads i wybieramy pozycję „Eclipse IDE for C/C++ 
Developers (includes Incubating components)” w  wersji Linux 
32- lub 64-bitowej (w chwili pisania artykułu jest to wersja IN-
DIGO (3.7.0) „ważąca” 107 MB). Następnie wybieramy serwer, 
z którego ma być pobrany plik i zapisujemy go na dysku (domyśl-
nie w folderze ~/Downloads). Należy pamiętać, że wszystkie pliki 
internetowe można pobrać również za pośrednictwem konsolowej 
przeglądarki internetowej, na przykład Lynx. Archiwum rozpako-
wujemy w trybie graficznym lub poprzez konsolę poleceniem (na-
zwa pliku może być inna w zależności od pobranej wersji):
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./arm-2011.09-69-arm-none-eabi.bin
W przypadku wystąpienia komunikatu:

bash: ./arm-2011.09-69-arm-none-eabi.bin: 
Permission denied
należy nadać odpowiednie uprawnienia do uruchomienia pliku 
poprzez:
chmod a+x arm-2011.09-69-arm-none-eabi.bin

Podczas uruchamiania pliku binarnego może się okazać, że 
aktualnie używany system shell (w przypadku Ubuntu domyśl-
nie ustawiony jest DASH) nie jest wspierany przez instalator 
(rysunek 1). Zmieniamy go poleceniem:
sudo dpkg-reconfigure -plow dash
a  następnie wybieramy No. W  konsoli powinniśmy otrzymać 
listing jak na rysunku 2. Po instalacji, jeżeli będziemy chcieli 
przywrócić domyślny system shell, należy po uruchomieniu po-
lecenia rekonfiguracji wybrać opcję Yes.

Po uruchomieniu pliku binarnego, otworzy się graficzny in-
stalator. Klikamy Next, akceptujemy licencję, Next, znów Next, 
wybieramy opcję Typical i klikamy Next. Następnie należy wy-
brać ścieżkę instalacji. Jeżeli chcemy zainstalować to oprogramo-
wanie dla różnych użytkowników systemu, to musimy wybrać 
odpowiedni folder i  nadać plikom odpowiednie uprawnienia. 
Jednak na potrzeby tego kursu, pakiet zostanie zainstalowany 
w domowym folderze użytkownika – w moim przypadku nazwa 
użytkownika to wojtek (rysunek 3): /home/wojtek/development/
CodeSourcery/ Klikamy na Next, następnie wybieramy opcję 
„Modify PATH for current user”,  Next, w opcji Other wpisuje-
my lokalizację /home/wojtek/development/CodeSourcery/links 
i klikamy Next. Jeżeli wszystko się zgadza na wyświetlonym mo-
nicie (rysunek 4), możemy kliknąć na Install. Po zakończonej 
instalacji odznaczamy opcję „View Getting Started guide?”, Next 
i Done. Istnieje również możliwość instalacji pakietu tylko z po-
ziomu konsoli, bez okienkowego trybu graficznego. Taki rodzaj 
instalacji urachamiamy poprzez wpisanie w konsoli:
./arm-2011.09-69-arm-none-eabi.bin -i 
console

Początek instalacji konsolowej został przedstawiony na 
rysunku 5. Instalator poprowadzi nas przez te same kroki co 
w  trybie graficznym. Różnica polega na tym, że wszystkie 
opcję musimy zatwierdzać z  klawiatury (uwagę należy zwró-

cić, że aby zatwierdzić 
umowę licencyjną znakiem 
‚Y’, należy ją pierwsze całą 
przeglądnąć, wielokrotnie 
naciskając klawisz Enter). 
Instalacje przerwać moż-
na w  dowolnym momen-
cie wpisując komendę quit 
w  konsoli. Po ukończonej 
instalacji jednym z  wyżej 
opisanych sposobów, można 
rozpocząć integrację środo-
wiska dla mikro-
kontrolerów ARM.

Pierwszy 
projekt

Jako kod do 
kompilacji po-
służy przykła-
dowy projekt 
testowy dla mi-
krokontrolerów 
EFM32 Gecko 
(ARM Cortex-M3) 
firmy Energy Mi-
cro. W  celu za-
chowania hierar-
chii plików i  ka-
talogów, a zarazem ścieżek do potrzebnych bibliotek oraz 
ułatwienia, katalog energymicro (utworzony po instalacji 
aplikacji Simplicity Studio ze strony www.energymicro.
com) wraz z zawartością zostanie skopiowany z window-
sowej partycji do lokalizacji /home/wojtek/development/ 
– można tego dokonać w trybie graficznym lub poprzez 
konsolowe polecenie 
cp. Mając przykładowy, 
prosty projekt dla da-
nego mikrokontrolera, 
dużo łatwiej jest zaczy-
nać tworzyć oprogra-
mowanie dla ARM’ów. 
Zatem zachęcam, aby 
na forum EP dzielić się 
projektami (szczególnie 
opartymi na pliku makefile) dla układów ARM – ATMEL, 
NXP, etc.

Będąc w lokalizacji /home/wojtek/development/eclip-
se uruchamiamy środowisko programistyczne poprzez 
plik eclipse. W  przypadku pierwszego uruchomienia 
środowiska zostaniemy poproszeni o wskazanie ścieżki 
do obszaru roboczego w którym chcemy obecnie praco-
wać (rysunek 6). Po wpisaniu ścieżki, można również 
zaznaczyć opcję, aby ten obszar roboczy był od teraz do-

Rysunek 1. Zamiana shell’a

Rysunek 2. Listing konfiguracyjny shell’a

Rysunek 3. Graficzny wybór katalogu instalacyjnego

Rysunek 4. Graficzne potwierdzenie 
wyboru konfiguracji instalacji

Rysunek 5. Instalacja kompilatora z poziomu 
konsoli

Rysunek 6. Wybór ścieżki z przykłado-
wymi projektami (Eclipse)

Rysunek 7. Ekran startowy (Eclipse)
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się, że w polu Build command znajduje się make. Następ-
nie w dolnym obszarze okna klikamy przycisk Workspace 
i wybieramy z naszego projektu folder codesourcery jako 
lokalizację pliku makefile potrzebnego do zbudowania 
tego projektu. Klikamy OK. Teraz okno powinno wyglą-
dać jak na rysunku 11. Klikamy przycisk Apply. Teraz 
przechodzimy po lewej stronie do pozycji Settings w C/
C++ Build. W zakładce Binary Parsers zaznaczamy opcję 
GNU Elf Parser, a następnie w dwóch dolnych polach wy-
bieramy pliki: /home/wojtek/development/CodeSourcery/
bin/arm-none-eabi-addr2line oraz /home/wojtek/develop-
ment/CodeSourcery/bin/arm-none-eabi-c++filt (rysunek 
12), klikamy Apply, a następnie OK. Teraz odznaczamy 
w górnym menu opcję Build Automatically, aby za każ-
dym razem automatycznie nie przebudowywał nam się 
projekt, co może być uciążliwe przy dużej ilości plików 
z  kodem. Pozostaje jeszcze tylko edycja pliku makefi-
le. W  naszym projekcie 
w  folderze codesourcery 
zmieniamy nazwę pliku 
Makefile.blink na make-
file i  edytujemy go. Po-
nieważ nie jest to artykuł 
o składni plików makefi-
le, to zaznaczę tylko, że 
do poprawnej kompilacji 
naszego projektu należy 
zmienić linię: LINUXCS 
= /cad/codesourcery/

myślnym obszarem roboczym (w przyszłości można go 
zmienić klikając na File > Switch Workspace > Other). 
W chwili obecnej wskazujemy na ścieżkę w której znaj-
dują się przykładowe projekty dla mikrokontrolerów 
EFM32: /home/wojtek/development/energymicro/boards/
EFM32_Gxxx_STK/examples i klikamy OK. Następnie kli-
kamy na ikonę Workbench (rysunek 7) i naszym oczom 
powinien się ukazać podstawowy wygląd okien Eclipse’a 
(rysunek 8).

Po lewej stronie, w  oknie zakładki Project Explorer 
klikamy prawym przyciskiem myszy, a następnie wybie-
ramy opcję Import... Rozwijamy pozycję C/C++, wybie-
ramy Existing Code as Makefile Project (rysunek 9) i kli-
kamy Next. Dla pola Existing Code Location za pomocą 
przycisku Browse lub wpisując z klawiatury wybieramy 
ścieżkę do projektu mrugających diod: /home/wojtek/de-

velopment/energymicro/
boards/EFM32_Gxxx_
STK/examples/blink oraz 
odznaczamy pole języka 
C++, a  jako Toolchain 
wybieramy <none> (ry-
sunek 10). Klikamy Fi-
nish. Zaleca się zrobienie 
kopii zapasowej folderu 
blink w  naszej lokaliza-
cji, w  razie gdybyśmy 
chcieli jeszcze z  niego 
kiedyś skorzystać w ory-
ginalnej wersji. Teraz nie-
zbędne jest ustawienie 
naszego projektu tak, aby 
był on możliwy do kom-
pilacji przez Sourcery 
CodeBench. W oknie Pro-
ject Explorer klikamy pra-
wym przyciskiem myszy 
na nasz projekt blink 
i  wybieramy Properties. 
Po lewej stronie wybie-
ramy pozycję C/C++ 
Build. W  zakładce Buil-
der Settings odznaczamy 
opcję Use default build 
command i  upewniamy 

Rysunek 8. Podstawowy widok środowiska (Eclipse)

Rysunek 9. Importowanie przykłado-
wego projektu

Rysunek 10. Konfiguracja projektu

Rysunek 11. Wybór kompilatora

Rysunek 12. Wybór kompilatora c.d.

Rysunek 13. Czyszczenie projektu
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arm-none-eabi/arm-2010q1 na LINUXCS 
= /home/wojtek/development/CodeSour-
cery

Wszytko jest już gotowe. Dla spraw-
dzenia poprawności kompilacji od same-
go początku wyczyśćmy jeszcze nas pro-
jekt. Klikamy w górnym menu na Projekt 
> Clean. Zaznaczamy opcję Clean all pro-
jects, a  odznaczamy Start a  build imme-
diately (rysunek 13) i klikamy OK. Osta-
tecznie klikamy w menu Project > Build 
All lub naciskamy kombinację klawiszy 
Ctrl+B. Jeżeli nasz projekt zbuduje się bez 
błędów, to w logu okna Console powinien 
pojawić się pod koniec komunikat Cre-
ating binary file, a w oknie Project Explo-
rer pliki wynikowe blink.out oraz blink.
bin (rysunek 14), które są plikami wsado-
wymi do pamięci flash mikrokontrolera. 
Mogą służyć również do debugowania.

Jeżeli występują problemy z  typem 
uint32_t w postaci błędu lub ostrzeżenia 
Type ‚uint32_t’ could not be resolved, nale-
ży wejść w górne menu Window > Preferences, a następ-
nie w opcję Language Mappings z listy C/C++ i zmapo-
wać (za pomocą przycisku Add) Content Type: C Header 
File i C Source File z Language: GNU C, kliknąć Apply, 
następnie OK i zrestartować Eclipse. 

Podsumowanie
Posiadanie w swoim komputerowym zapleczu takie-

go darmowego, nieograniczonego, zintegrowanego środo-
wiska programistycznego dla mikrokontrolerów ARM jest 
nieocenione w  przypadku, gdy pracujemy na systemie 
operacyjnym Linux i nie mamy możliwości przełączenia 
się na Windowsa. W chwili obecnej wiele osób korzysta 
z  netbooków, których ograniczone zasoby skłaniają do 
zastosowanie jednej z dystrybucji Linuxa zamiast Win-
dowsa. Dzięki mobilności tych komputerów jesteśmy 
w stanie dokonywać poprawek kodu i kompilacji będąc 
„w terenie”. Dodatkowo, niewątpliwym plusem jest moż-
liwość edytowania i budowania projektu za pomocą linii 
komend w  Linuxie. Choć tworzenie projektu może nie 
jest wygodne i efektywne za pomocą konsolowych edyto-
rów, to w nagłych, awaryjnych przypadkach, o ile mamy 
zdalny dostęp (na przykład poprzez SSH) do kompute-
ra na którym jest zainstalowane linuxowe środowisko 
programistyczne, możemy za pomocą konsoli edytować 
pliki źródłowe (rysunek 15), a  następnie będąc w  ka-

Rysunek 14. Listing po udanej kompilacji projektu

Rysunek 15. Edycja projektu bez pomocy środowiska 
Eclipse

talogu codesourcery naszego projektu wpisać komendę 
make i skompilować projekt (lub na przykład make cle-
an w  celu wyczyszczenia projektu). Należy pamiętać, 
aby przy instalacji i  konfiguracji środowiska podawać 
poprawne ścieżki dostępu, których składowe mogą się 
zmieniać, jak na przykład ścieżki zawierające folder do-
mowy użytkownika czy lokalizacje projektów.

Wojciech Gelmuda
AGH Akademia Górniczo-Hutnicza
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