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Sprzęt
Urządzenie testowano i uruchamiano na platformie sprzęto-

wej eMeSPek. Przed rozpoczęciem pracy z płytką, należy wykonać 
zmianę w mozaice obwodów drukowanych. Konieczne jest prze-
cięcie pokazanej na fot. 1 ścieżki drukowanej. Modyfikacja układu 
sprawi, że zworka JP4 zacznie pełnić swoją funkcję.

Zworka JP4 odpowiada za konfigurację źródła zasilania ukła-
du. Ustawiona w pozycji 1-2 powoduje, że układ jest zasilany 
z baterii. Konfiguracja 2-3, doprowadza do układu zewnętrzne za-
silanie. W aplikacji wykorzystywane będą diody LED, więc przed 
jej uruchomieniem zworki JP1 oraz JP2 należy ustawić w pozy-
cji 1-2. Konfiguracji wymaga również źródło sygnału zegarowego 
LFXT1CLK. Zastosowano kwarc zegarkowy XT2 o częstotliwości 
32768 Hz. W związku z tym zworki JP5 i JP6 należy ustawić w po-
zycji 1-2. Pomiary analogowe nie korzystają z zewnętrznego napię-
cia referencyjnego, nie ma więc konieczności dołączania do pinu 
P2.4 kondensatora C10 i zworka JP7 może zostać zdjęta, albo usta-
wiona w pozycji 1-2.

Funkcjonalność
Jak sama nazwa wskazuje, termometr mierzy temperaturę oto-

czenia. Pomiar wykonywany jest cyklicznie. Użytkownik ma moż-
liwość konfiguracji czasu pomiędzy pomiarami. Minimalna war-
tość to 1 sekunda, maksymalna – 65534 sekund (ok. 1,5 miesiąca). 
Poza cyklicznym pomiarem temperatury możliwe jest wykonanie 
pomiaru na żądanie. W tym celu należy wcisnąć jeden z dostęp-
nych na płycie eMeSPek przycisków – SW1 lub SW2.

Po zakończeniu pomiaru, wynik zapisywany jest w wewnętrz-
nej pamięci Flash mikrokontrolera. Wraz z temperaturą do pamię-
ci zapisywany jest czas wykonania pomiaru. W sumie to 8 bajtów 
danych.

Maksymalnie w pamięci można zapisać 448 rekordów danych 
(czas+temperatura). W dowolnym momencie pracy urządzenia 
użytkownik ma możliwość odczytu zarejestrowanych danych. Ist-
nieje również możliwość skasowania danych i rozpoczęcia cyklu 
pomiarowego od początku.

Organizacja pamięci FLASH
Darmowa wersja środowiska IAR posiada ograniczenie na roz-

miar kodu wynikowego. Ograniczenie dotyczy projektów pisanych 
w języku C oraz C++. W przypadku tego typu projektów; czyli rów-
nież projektu przenośnej stacji meteorologicznej; maksymalny roz-
miar kodu wynikowego nie może być większy niż 4 kB. Należy pa-
miętać, że ograniczenie dotyczy jedynie wielkości kodu stworzonego 
przez programistę. Używając wbudowanych bibliotek (np.: funkcji 
strlen, sprintf) można wygenerować kod o większej objętości.

MSP430
Termometr z rejestracją

W styczniowym numerze Elektroniki Praktycznej 
(EP 01/2009) rozpoczęliśmy publikację kursu 

programowania mikrokontrolerów MSP430 (seria 
x1xx). Na zakończenie kursu autor prezentuje 

projekt termometru z możliwością rejestracji 
zmierzonej temperatury. Projekt został wykonany 

w oparciu o dostępną w ofercie AVT płytkę 
ewaluacyjną eMeSPek.

Mikrokontroler MSP430 f1232 ma 8 kB pamięci FLASH przezna-
czonej na kod programu. Część z tej pamięci wykorzystano do reje-
stracji zmierzonej temperatury. 

Do projektu dołączono plik lnk430F1232.xcl (Project->Options, 
Linker->Config) opisujący pamięć FLASH mikrokontrolera. W pliku 
tym obszar pamięci kodu programu ograniczono do 4 kB (–P(CODE-
)CODE=E000–EFFF). Uzyskane w ten sposób miejsce przeznaczono 
na rejestrowane dane (–P(CODE)METEO=F000–FDFE). W sumie 
przeznaczono na nie 3584 B pamięci FLASH, co przy rozmiarze 
jednego rekordu danych 8 B daje możliwość zarejestrowania 448 re-
kordów. Dane rejestrowane są począwszy od adresu 0xF000, aż do 
momentu zapełnienia się pamięci. Wówczas pomiar temperatury oraz 
rejestracja danych zostają wstrzymane i włączana jest dioda D1, któ-
rej świecenie informuje użytkownika o zapełnieniu się pamięci i tym 
samym zakończeniu cyklu pomiarowego.

W projekcie wykorzystywana jest pamięć informacyjna mikro-
kontrolera. W segmencie B tejże 
pamięci, pod adresem 0x1000, zapi-
sywany jest parametr konfigurujący 
czas pomiędzy pomiarami.

Programowanie
Zworkę JP4 należy ustawić 

w pozycji 2-3. Następnie podłączyć 
zewnętrzne zasilanie oraz progra-
mator. Otworzyć projekt Meteo.
eww i zaznaczyć w opcjach debuger 
kasowanie pamięci programu oraz 
pamięci informacyjnej podczas pro-
gramowania. Po zaprogramowaniu 
mikrokontrolera (Project->Debug), 
uruchomić program (Debug->Go), 
a następnie wyjść z debugera (De-
bug->Stop Debugging). Urządzenie 
zostało zaprogramowane. Można 
odłączyć programator, usunąć zwor-
kę JP4 oraz odłączyć zewnętrzne za-
silanie.

Fot. 1.

Rys. 2.

Dodatkowe 
materiały na CD

Przykładowa aplikacja
na podsumowanie kursu

KURS
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terminala to 8N1, wyłączona kontrola sprzętową, prędkość transmisji 
9600 bps. Komunikacja z układem odbywa się przy pomocy komend 
tekstowych opisanych w tabeli numer 1. Komendy muszą być zakoń-
czone znakiem CR, gdyż tylko wówczas są analizowane przez wbudo-
wane oprogramowanie mikrokontrolera.

Na początku należy ustawić datę, oraz czas („DateTime=”), zgod-
nie z formatem „rr-mm-dd gg:mm:ss”. Aktualny czas i datę można od-
czytać przy pomocy komendy „DateTime?” i tym samy upewnić się 
czy moduł programowego zegara RTC pracuje prawidłowo. Kolejnym 
etapem konfiguracji urządzenia jest zdefiniowanie czasu pomiędzy 
pomiarami. Czas jest podawany w sekundach, a dostępne nastawy 
parametru to od 1 sekundy do 65534 sekund (około 1,5 miesiąca). 
Po ustawieniu parametru („Interval=”), i upłynięciu zdefiniowanego 
czasu urządzenie rozpoczyna cykliczne pomiary temperatury oraz 
zapis wyników w pamięci danych rejestrowanych. Użytkownik może 
zatrzymać pomiary, konfigurując czas pomiędzy pomiarami na jedną 
z wartości 0, albo 65535.

W dowolnym momencie działania urządzenia użytkownik może 
odczytać zarejestrowane parametry („MeteoData?”). Możliwe jest rów-
nież skasowanie danych rejestrowanych („Erase!”). Podczas kasowa-
nia pamięci danych rejestrowanych włączona jest dioda D1. Proces 
kasowanie trwa niecałe 90 ms, dlatego też użytkownik może zaobser-
wować jedynie krótkotrwałe mignięcie diody D1.

Po zakończeniu konfiguracji (rys. 3), termometr jest gotowy do 
użycia. Autor artykułu, wykorzystał urządzenie do pomiaru tempe-
ratury w przydomowym ogródku. Pomiary wykonywane były co 4 
minuty przez 24 godziny, a ich wyniki były zapisywane w pamięci 
danych. Rezultat pomiarów pokazano na rys. 4. 

Struktura programu
Aby maksymalnie wydłużyć czas pracy urządzenia na jednym 

komplecie baterii, wbudowane oprogramowanie zostało zoptymalizo-
wane pod kątem energooszczędności. Jako źródło sygnału LFXT1CLK 
skonfigurowano kwarc niskiej częstotliwości (kwarc zegarkowy 
32768 Hz). Częstotliwości sygnałów zegarowych mikrokontrolera do-
brano następująco: ACLK=LFXT1CLK=32768 Hz, MCLK=SMCLK
=DCO= ok. 720 kHz.

Przez większość czasu działania programu mikrokontroler prze-
bywa w trybie uśpienia LPM3 (pobór prądu 0,7 mA, ACLK pozosta-
je włączone, pozostałe sygnały zegarowe są wyłączone). Przerwania 
od modułów peryferyjnych 
budzą CPU. W momencie 
zgłoszenia przerwania uru-
chamiany jest zegar DCO. 
Po około 6 ms (czas startu 
DCO), mikrokontroler prze-
chodzi w tryb pracy aktyw-
nej AM (wszystkie sygnały 
zegarowe są włączone, po-
bór prądu ok. 170 mA), wy-
konuje zdefiniowane w ko-
dzie programu zadania, po 
czym powraca w tryb uśpie-
nia LPM3.

W trybie normalnej pra-
cy mikrokontroler jest bu-
dzony w wyniku przerwań 
generowanych przez moduł 
zegara TimerA. Cyklicznie, 
zgłaszane są przerwania od 
liczników TACCR0, TAC-
CR1. Przerwania od licz-
nika TACCR1 są zgłaszane 
co sekundę. W procedurze 
obsługi przerwania odświe-

IAR – tricks & tips
W trybie debugera środowiska IAR, programista ma możliwość pod-
glądania pamięci FLASH mikrokontrolera (View->Memory). Programując 
urządzenie (Project->Options, FET Debugger) ma natomiast możliwość 
wyboru czy będzie kasowana tylko pamięć programu (Erase main memo-
ry), czy też wraz z nią pamięć informacyjną (Erase main and Information 
memory). W pamięci informacyjnej znajduje się parametr konfiguracyjny, 
a w pamięci programu – poza kodem programu – rejestrowane dane. 
Jeśli, programista nie chce kasować znajdujących się w pamięci danych, 
to może skorzystać z trzeciej dostępnej opcji programowania urządzenia 
(Retain unchanged memory). Wówczas kod programu zostanie podmie-
niony, a obszar danych konfiguracyjnych oraz danych rejestrowanych 
pozostaną nienaruszone.
W projekcie pamięć kodu programu ograniczono do 4 kB. Kod wynikowy 
aplikacji nie może być większy niż zadeklarowana wielkość pamięci. Z te-
go powodu w projekcie włączono optymalizacją kodu (Project->Options, 
C/C++ compiler->Optimizations). Rozmiar kodu wynikowego programu 
programista może sprawdzić w oknie kompilacji projektu (Project->Rebuild 
All). Jeśli programista potrzebuje bardziej szczegółowych informacji o ko-
dzie wynikowym, to powinien w opcjach projektu, w kategorii C/C++ 
compiler, zakładce List zaznaczyć opcję Output list file. Wówczas na eta-
pie kompilacji, dla każdego z pliku projektu zostanie wygenerowany plik 
z rozszerzeniem .lst (katalog Debug/List). W pliku poza listingiem kodu 
programu znajdą się informacje na temat zajętości stosu programu, oraz 
objętości kodu wynikowego programu. Informacje te są wręcz niezbędne 
podczas optymalizacji oprogramowania.
W aplikacji układ watchdog odświeżany jest co 0,5 sekundy. Jeśli 
programista zamierza debugować projekt, to powinien zatrzymać układ 
watchdog. W projekcie (Project->Options, C/C++ compiler->Preprocessor) 
zadeklarowano dyrektywę preprocesora o nazwie WDT_ON. Zmiana tej 
nazwy powoduje, że na etapie kompilacji generowany jest kod programu 
z wyłączonym układem watchdog.
Przed rozpoczęciem debugowania projektu, należy wyłączyć aktywne 
pułapki sprzętowe. Zaprogramować mikrokontroler i dopiero wówczas 
ustawić pułapki. W przypadku mikrokontrolerów serii x1xx, programista 
ma możliwość ustawienia od 2 do 8 pułapek sprzętowych (w zależności 
od typu mikrokontrolera). Ograniczenie liczby pułapek sprzętowych bywa 
uciążliwe. Można je jednak ominąć. W opcjach projektu należy wybrać 
stosowanie pułapek programowych (Options, FET Debugger, Breakpoints-
->Use Software Breakpoints). Wówczas możliwe będzie korzystanie 
z nieograniczonej liczby pułapek. Niestety nie ma niczego za darmo. 
Decydując się na korzystanie z pułapek programowych godzimy się na 
to, że podczas debugowania program nie będzie wykonywany w czasie 
rzeczywistym.

Rys. 3

Uruchomienie, konfiguracja
Aby płytka eMeSPek stała się urządzeniem przenośnym, należy 

w koszyku B1 umieścić baterię typu CR2032, a następnie przełączyć 
zasilanie układu na bateryjne (JP4 w poz. 1-2). Rozpocznie się inicjali-
zacja układów peryferyjnych, a następnie zostanie wykonany pomiar 
napięcia zasilania mikrokontrolera – w naszym przypadku napięcia 
baterii. Jeśli zmierzona wartość będzie mniejsza niż 2,7 V, to zostaną 
włączone diody D1 oraz D2, a urządzenie przejdzie w tryb pracy awa-
ryjnej. Przejście w tryb awaryjny oznacza wstrzymanie normalnej pra-
cy urządzenia. Zabezpieczenie zostało wprowadzone ze względu na 
minimalną wartość napięcia wymaganą podczas zapisu i kasowania 
pamięci FLASH. W przypadku serii x1xx do programowania pamięci 
wymagane jest napięcie o wartości co najmniej 2,7 V.

Jeśli po uruchomieniu urządzenia diody nie są włączone, oznacza 
to, że bateria dostarcza napięcia o właściwej wartości, a urządzenie 
przeszło w tryb pracy normalnej. Oprogramowanie rozpoczyna prze-
szukiwanie pamięci danych rejestrowanych w celu znalezienia indek-
su ostatnio zarejestrowanej próbki (algorytm połowienia). Inicjowany 
jest parametr określający czas pomiędzy pomiarami. Następnie rozpo-
czyna się wykonywanie pętli głównej programu. W związku z tym, że 
urządzenie nie zostało skonfigurowane, to nie posiada pełnej funkcjo-
nalności (nie są wykonywane cykliczne pomiary temperatury). Uru-
chomione zostały: moduł zegara RTC (od bazowej wartości 2001-01-01
00:00:00), komunikacja RS-232, oraz pomiary na żądanie.

Aby urządzenie było w pełni funkcjonalne należy je skonfiguro-
wać. W tym celu konieczne jest podłączenie urządzenia do kompute-
ra z uruchomionym terminalem portu szeregowego. Parametry pracy 
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żany jest rejestr układu watchdog (czas wykonania kodu programu 
około 35 ms).

Licznik TACCR0 również generuje przerwania, co jedną sekun-
dę. W procedurze obsługi przerwania odświeżany jest również układ 
watchdog. Dodatkowo uaktualniany jest czas zegara RTC, a oprogra-
mowanie sprawdza czy powinno rozpocząć (tzw. cykliczny) pomiar 
danych rejestrowanych (czas wykonania około 75 ms). Reasumując, 
zaledwie przez czas około 110 ms mikrokontroler przebywa w trybie 
aktywnym AM (170 mA), pozostałą część sekundy pozostaje uśpiony 
LPM3 (0,7 mA).

W momencie, gdy w procedurze obsługi przerwania od licznika 
TACCR0 zostanie wykryta potrzeba wykonania pomiaru danych re-
jestrowanych, nastąpi opuszczenie trybu energooszczędnego LPM3. 
Oprogramowanie rozpocznie wykonywanie pętli głównej aplikacji. 
W niej zostanie wykonany pomiar temperatury (około 800 ms), oraz 
zapis danych do pamięci FLASH (około 1 ms). Następnie oprogramo-
wanie powróci w tryb normalnej pracy. W identyczny sposób aplika-
cja zachowa się w przypadku wykrycia potrzeby wykonania pomiaru 
na żądanie (procedura obsługi przerwań portu drugiego). 

Opuszczenie trybu pracy LPM3 i przejście do wykonywania pętli 
głównej ma również miejsce w przypadku procedury obsługi przerwa-
nia od modułu komunikacji UART. Sytuacja taka ma miejsce w mo-
mencie, gdy zostanie wykryte odebranie poprawnej komendy (zakoń-
czonej znakiem CR). W pętli głównej odbędzie się analiza odebranej 
komendy, ewentualne jej wykonanie oraz wysłanie odpowiedzi. Pod-

czas trwania wymienionych operacji, pomiar danych rejestrowanych 
będzie wstrzymany (odczyt danych, kasowanie danych, etc.).

Komunikacja pomiędzy procedurami przerwań, a pętlą główną 
oprogramowania odbywa się przy wykorzystaniu procedur zdefinio-
wanych w pliku Control.c.

W trakcie wykonywania pętli głównej oprogramowania mikro-
kontroler przebywa w trybie pracy aktywnej AM. Pobór prądu wynosi 
około 170 mA. Należy jednak pamiętać, że pomiar temperatury oraz 
zapis danych do pamięci FLASH, wpływają na zwiększenie poboru 
energii.

Źródła projektu
Projekt termometru jest swego rodzaju podsumowaniem cyklu ar-

tykułów na temat MSP430. Wykorzystano w nim wszystkie moduły 
peryferyjne omawiane we wcześniejszych artykułach. Pliki źródłowe 
projektu umieszczono na płycie CD-EP5/2009A. Aplikację napisano 
w taki sposób, aby jej wartość dydaktyczna była jak największa (po-
miar temperatury z wewnętrznego czujnika, sekcja danych konfigura-
cyjnych, danych pomiarowych, implementacja programowego zegar 
RTC i inne). Czytelnik ma możliwość modyfikacji kodu programu 
aplikacji. Może również wykorzystywać ów kod w przypadku wła-
snych rozwiązań tworzonych w oparciu o energooszczędne mikro-
kontrolery MSP430. 

Łukasz Krysiewicz

Rys. 4.

Tab. 1 – Komendy protokołu komunikacyjnego

Komenda Opis Format danych 
wejściowych Odpowiedź Przykład, wywołania oraz 

odpowiedzi.

DateTime? Odczyt daty, oraz czasu. Brak. rr-mm-dd gg:mm:ss
.:Ok.:.

DateTime?
09-04-28 16:56:23

.:Ok.:.

DateTime= Ustawienie daty, oraz czasu. rr-mm-dd gg:mm:ss 1) .:Ok.:.
2) .:Error:.

DateTime=09-04-28 16:44:02
.:Ok.:.

Interval= Ustawinie czasu pomiędzy 
pomiarami. Liczba z zakresu 0-65535. 1) .:Ok.:.

2) .:Error:.
Interval=240

.:Ok.:.

MeteoData? Odczyt danych rejestrowa-
nych. Brak.

.:Ok.:.
rr-mm-dd gg:mm:ss  

temperatura.

MeteoData?
:Ok.:.

09-04-28 06:58:02 7.79
09-04-28 07:02:02 8.20
09-04-28 07:06:02 8.20

Erase! Kasowanie danych rejestro-
wanych. Brak. .:Ok.:. Erase!

.:Ok.:.

Niepoprawna komenda Wprowadzenie niepoprawnej 
komendy. Brak. .:Unknown:. DaTeTiMe!

.:Unknown:.


