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Terrarium dla ,,gekona”

Zintegrowane srodowisko
programistyczne dla
mikrokontrolerow EFM32 (1)

W 9/2010 EP zostala zaprezentowana rodzina mikrokontroleréw
EFM32 firmy EnergyMicro (Gecko, TinyGecko). Jesli ktos potrzebuje
zastosowaé w swoich aplikacjach uklady o niskim poborze

prqdu z mocq obliczeniowq rdzenia ARM Cortex-M3 lub po
prostu chce poddaé probie marketingowe hasta producentéw tych
mikrokontroleréw, to ten artykul moze okazac sie bardzo pomocny.

Kazdy widzi, jaki jest ,,gekon”
Rodzina mikrokontroler6w EFM32 jest
bardzo interesujgca. Inzynierowie z firmy
EnergyMicro postanowili zmniejszy¢é pobér
pradu przez caly uklad scalony przy zacho-
waniu mocy obliczeniowej rdzenia ARM
Cortex-M3. Udalo sie to dzieki odlaczaniu
zasilania i sygnaléw zegarowych od modu-
16w, ktére w danej chwili nie sg potrzebne.
Dodatkowo, opracowano kilka specjalnych
trybéw oszczedzania energii (Energy Modes),
ktére w polaczeniu z peryferiami typu LE
(Low Energy), komunikacja miedzymoduto-
wa bez uzycia procesora (Peripheral Reflex
System), kanalami DMA oraz mozliwoscig
taktowania peryferii typu LE z ,zegarkowe-
go” rezonatora kwarcowego pozwalaja na
znaczne obnizenie poboru mocy przez caty
uktad. Dzieki temu mikrokontrolery EFM32
znajduja zastosowanie szczeg6lnie w aplika-
cjach zasilanych bateryjnie oraz gdy zaistnie-
je potrzeba zwigkszenia mocy obliczeniowe;j
w aplikacjach opartych na popularnych mi-
krokontrolerach 8- lub 16-bitowych.

Wybér ,,gekona”

Uktady EFM32 sg do naszej dyspozycji
w réznych obudowach — od BGA, poprzez
QFN, na QFP koniczac. Do wyboru mamy
réwniez ilo§¢ pamieci Flash naszego gada
(w chwili obecnej do 128kB) oraz liczbe ,,n6-
zek”, jakg dysponuje (od 24 do 112). Dzieki
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Rysunek 1. Zaznaczenie opgji
zapamietania lokalizacji domysinej
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tak szerokiemu wyborowi jesteémy w stanie
dobra¢ optymalny dla nas uktad.

Na rynku znajduje sig kilka plytek ewa-
luacyjnych z naszym pupilem, migdzy inny-
mi plytki firmy Olimex, ktérych cena zostata
,uszyta” na kazdg kieszen. Jednak co za tym
idzie, liczba peryferii na ptytce jest znikoma.
Innym rozwigzaniem jest zakup oficjalnej
plytki z EFM32 firmy EnergyMicro. W chwi-
li obecnej dostepne sg dwa typy plytek: te-
stowa (STK) i rozwojowa (DK). Sugerowane
ceny podane na stronie firmy to odpowied-
nio 69 i 299 USD (o szczeg6ly i konkretne
ceny nalezy pytac¢ u polskich dystrybutoréw
lub w sprzedazy internetowej). Pierwsza
plytka zapewnia podstawowe peryferia te-
stowe i co istotne, ma mozliwos¢ zasilania
bateryjnego. Natomiast ptytka rozwojowa ma
wiele moduléw pozwalajgcych testowaé na-
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Rysunek 3. Okno Project Explorera

sze aplikacje i co wazne, wszystkie piny mi-
krokontrolera sg wyprowadzone na zewnatrz
i mamy do nich dostep.

Przy wyborze plytki ewaluacyjnej do
rozpoczecia pracy z naszymi gekonami klu-
czowym moze okazac sie fakt, iz plytki Ener-
gyMicro — zar6wno testowa, jak i rozwojowa
— zawierajg debugger J-Link firmy SEGGER
typu OEM. Dzieki temu nie potrzeba juz
kupowa¢ dodatkowych urzagdzen do pro-
gramowania i testowania mikrokontroleréw
EFM32. Istotng kwestig jest to, ze gekonéw
EnergyMicro nie mozna programowac i de-
bugowaé poprzez popularny interfejs JTAG,
a jedynie poprzez interfejs SWD (Serial Wire

Workbench

Go to the workbench

Rysunek 2. Przejscie do obszaru roboczego
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Rysunek 5. Importowanie projektu

Debug). Zatem jezeli posiadamy juz jakis
ulubiony programator i chcemy z niego ko-
rzystac, to nalezy upewnic sie, czy mozna go
ustawi¢ w tryb SWD.

Wsparcie ,,hodowcy”

Zespol z EnergyMicro stanal na wyso-
kosci zadania, jezeli chodzi o wsparcie dla
swoich mikrokontroleréw. Oprécz udostep-
nienia bibliotek do peryferii mikrokontrole-
ra i plytek ewaluacyjnych, kompatybilnosci
z CMSIS (Cortex Microcontroller Software In-
terface Standard), mozna za darmo $ciagnaé
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Rysunek 6. Dotaczenie plikow do projektu
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Rysunek 8. Ustawienia kompilatora w Eclipse

sobie ze strony internetowej firmy programy
wspomagajace projektowanie aplikacji na
bazie gekonéw EFM32 — energyAware Desi-
gner (generacja szablon6w kodu dla ré6znych
konfiguracji pinéw) i energyAware Profiler
(symulacje poboru pradu ukladu w réznych
konfiguracjach). Dziegki takiemu wsparciu
zarOwno rozpoczecie pracy z nowym mikro-
kontrolerem, jak i zgtebianie jego mozliwosci
staja sie o wiele prostsze. Dodatkowo stwo-
rzony zostal specjalny portal wsparcia tech-
nicznego dla rodziny EFM32 (http://support.
energymicro.com/home).

Kolejnym bardzo dobrym posunieciem
ze strony EnergyMicro jest wspieranie du-
zej liczby kompilatoréw i debuggeréw, za-
réwno tych z wyzszej p6iki, jak i tych na
kazda kieszen. Do kazdej plytki ewaluacyj-
nej dodawana jest darmowa, ewaluacyj-
na wersja Srodowiska programistycznego
przeznaczonego dla mikrokontroleréow
z rdzeniem ARM - IAR Embedded Work-
bench. Jednak aby w petlni cieszy¢ si¢ moz-
liwosciami naszego gada, nie potrzebuje-
my kupowac¢ drogich ,kombajnéw”. Mozna
zlozy¢ sobie z darmowych aplikacji cal-

kiem przystepne srodowisko dla gekonéw
z EnergyMicro.

Budujemy terrarium

Nasze zintegrowane $rodowisko progra-
mistyczne dla mikrokontroleréw z rodziny
EFM32 bedzie dziatalo na systemie operacyj-
nym Windows.

Pierwsza rzeczg, jakg musimy zrobic, jest
Sciagniecie ze strony www.energymicro.com
(dzial Downloads, a nastepnie Software) i za-
instalowanie pakietu aplikacji, dokumentacji
i przykladéw o nazwie energyAware EFM32
Gecko Installer (w chwili pisania artykulu
jest to wersja rev. 1.5.0 (11/10) o wielko$ci
okoto 39 MB). Po wypakowaniu pliku insta-
lujemy aplikacje w domy$lnej lokalizacji (C:|
Program Files\Energy Micro\EFM32 Gecko
DK).

Poniewaz naszym $rodowiskiem progra-
mistycznym bedzie Eclipse, musimy mie¢
zainstalowang wirtualng maszyne Javy. Je-
§li mamy juz ja zainstalowang, to mozemy
omina¢ ten punkt. Jesli nie, to pobieramy ja
ze strony www.java.com i instalujemy w na-
szym systemie. Nastepnie pobieramy i roz-
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pakowujemy srodowisko Eclipse dla jezykow
programowania C/C++ ze strony www.ec-
lipse.org, dziat Downloads, zbiér Eclipse IDE
for C/C++ Developers. Nalezy wybra¢ wersje
32- lub 64-bitowa (w chwili pisania artykutu
jest to wersja HELIOS 3.6.1). Dla zgodnoésci
Sciezek dostepu z tym opisem nalezy rozpa-
kowa¢ $ciagniety plik bezposrednio na dysk
LG

Kolejnym krokiem jest instalacja kom-
pilatora. Poniewaz chcemy, aby caly zestaw
do pracy przy gekonach byl darmowy, cie-
kawa propozycja jest kompletny toolchain,
oparty na G++ (licencja GNU), pakiet firmy
CodeSourcery — Sourcery G++ Lite Edition.
W celu $ciagniecia go wchodzimy na strone
www.codesourcery.com, a nastgpnie wybie-
ramy z menu Products -> Sourcery G++ ->
Editions -> Lite. Na nowej stronie wybiera-
my interesujacg nas wersje, czyli ARM i na-
stepnie Download the current release, wersje
EABI i plik instalacyjny przeznaczony dla
systemu Windows, czyli IA32 Windows In-
staller (w moim wypadku wersja Sourcery
G++ Lite 2010q1-188). Ze strony mozemy
takze Sciagna¢ obszerng dokumentacjg do
toolchaina.

Instalacja jest doé¢ intuicyjna. Nalezy je-
dynie mie¢ na uwadze, aby byla zaznaczona
opcja modyfikacji $ciezki systemowej PATH.

Oprogramowanie niezbedne do zbu-
dowania programu dla mikrokontroleréw
EFM32 jest juz gotowe. Trzeba teraz tylko je
ze sobg powigzac. Zrébmy to zatem i skom-
pilujmy nasz pierwszy projekt. Miejmy na
uwadze fakt, ze kompilator G++ bedzie
uruchamiany z linii komend, wiec $ciezki
do plikéw badz katalogéw podawane mu nie
moga zawierac¢ spacji.

Uruchamiamy Eclipse. Jezeli jest to
pierwsze nasze uruchomienie, to zostaniemy
poproszeni o podanie $ciezki do domys$lnego
obszaru roboczego (Workspace). Wskazuje-
my lokalizacje folderu z przykladami do-
starczonymi przez EnergyMicro C:|\Program
Files\Energy Micro|\EFM32 Gecko DK\boards)
EFM32 Gxxx_STKlexamples 1 zaznaczamy
opcje zapamietania tej lokalizacji jako do-
my$lnej (rysunek 1). Nastgpnie przyciska-
my ikong pozwalajacg nam na przejscie do
obszaru roboczego (rysunek 2). Jezeli nie
jest to nasze pierwsze uruchamianie Eclipse
lub w przyszlosci bedziemy chcieli zmie-
ni¢ obszar roboczy, mozemy wpisaé nowg
Sciezke dostepu, klikajac w menu File ->
Switch Workspace -> Other. W oknie Pro-
ject Explorer (rysunek 3) klikamy prawym
przyciskiem myszy i wybieramy opcje New
-> C Project. W oknie wpisujemy nazwe no-
wego projektu ,test” i wybieramy opcje: Use
default location, Project type jako Makefile
Project -> Empty Project, a Toolchains jako
Other Toolchain. Potwierdzamy, klikajac na
Finish (rysunek 4). Nastepnie w oknie Pro-
ject Explorer klikamy prawym przyciskiem
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Rysunek 9. Ustawienie sciezek dostepu do parseréw

myszy na nowo otworzonym projekcie i wy-
bieramy Import, a z rozwijanego menu Ge-
neral -> File system, wybieramy Next (rysu-
nek 5). Wybieramy $ciezke projektu — mruga-
jacych diod — C:\Program Files\Energy Micro|
EFM32 Gecko DK\boards\EFM32_ Gxxx_STK|
examples\blink dla ptytki STK lub C:|\Pro-
gram Files\Energy Micro\EFM32 Gecko DK|
boards\EFM32_Gxxx_DKlexamples\blink dla
plytki DK. Do dolaczenia zaznaczamy folder
codesourcery oraz plik blink.c. Zakonczamy
Finish (rysunek 6). Dzieki takiemu rozwia-
zaniu (tworzenie osobnego projektu i im-
portowanie plikéw Zrédlowych) zostawiamy
w stanie nienaruszonym przyklad mruga-
jacych diod. Nastepnie za pomocg myszki
w oknie Project Explorer kopiujemy plik
Makefile.blink z folderu codesourcery bez-
posrednio do folderu projektu i zamieniamy
jego nazwe na makefile. Folder codesourcery
mozemy juz usunaé. Dzieki temu struktura
projektu wyglada znacznie prosciej i tatwiej
bedzie nam dodawaé $ciezki do kolejnych
komponentéw w pliku makefile. Wyglad
kompletnego drzewa projektu pokazano na
rysunku 7.

Po przeniesieniu pliku ,,makefile” musi-
my edytowac jego zawarto$¢. Otwieramy go
i zmieniamy nastepujace linijki:

DEVICE = EFM32G890F128 # W zaleznosci
od typu mikrokontrolera #

PROJECTNAME = test # Nazwa projektu #
TOOLDIR = ‘C:/Program Files/CodeSource-
ry/Sourcery G++ Lite’ # Sciezka do folderu
z pakietem CodeSourcery #

GCCVERSION = ’4.4.1°

W  zaleznoéci od wersji kompilatora
w niektérych przypadkach bedziemy musie-
li w powyzszych linijkach zamieni¢ znaki
(apostrof) na ” (cudzystéw), jezeli wystapia
btedy w kompilacji.

W linii zaczynajacej sie od LDFLAGS
usuwamy jeden czlon ,,../”. To samo robimy
w liniach:

S
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Rysunek 10. Wytaczenie opcji Build
Automatically

-I../..[..[..[../CMSIS/CM3/CoreSupport |
-I../../..]..]../CMSIS/CM3/DeviceSupport/Ener-
gyMicro/EFM32 |
-L.[..]..]..]..Jlefm32lib/inc |
-I../../../drivers
. ].]..]../[CMSIS/CM3/CoreSupport/core_
cm3.c
....]..]..]../CMSIS/CM3/DeviceSupport/Energy-
Micro/EFM32/system_efm32.c |
..[..1..[drivers/leds.c |
.l....]..]..lefm32lib/src/efm32_assert.c |
.).]..]..]..lefm32lib/src/efm32_system.c |
.f.]..]..]../ICMSIS/CM3/DeviceSupport/Energy-
Micro/EFM32/startup/cs3/startup_efm32.s
W linii:
../blink.c

usuwamy czlon ,,...”. Nastepnie zapisuje-
my zmiany wprowadzone w pliku.

Teraz ustawimy nasz kompilator w Ec-
lipse. Klikamy w menu Project -> Properties,

& cean loixj
ot the practs vell s rebust frorn serstih
" Cluan projects sulected below

= Cisn ol proects

Rysunek 11. Wytaczenie opcji auto-
matycznego budowania projektu po
wyczyszczeniu go
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Rysunek 12. Okno z przyktadowymi komunikatami po kompilacji wykonanej bez

btedow

nastepnie z listy po lewej stronie wybieramy
C/C++ Build. W zakladce Builder Settings
w polu Build command zamiast ,make”
wpisujemy ,cs-make” (mozliwe, ze bedzie

potrzebne odznaczenie opcji Use default

build command). Akceptujemy przyciskiem
Apply (rysunek 8). Nastgpnie w menu po
lewej stronie wybieramy C/C++ Build ->
Settings. W zakladce Binary parsers z listy
Binary parser zaznaczamy pozycje GNU Elf

Parser, a nastepnie klikamy w pozycje GNU
Elf Parser. Teraz w dolnej czesci zakladki,
za pomocg przyciskéw Browse, wskazujemy
$ciezke do plikéw parsera, czyli kolejno C:|
Program Files\CodeSourcery\Sourcery G+ +
Lite\bin\arm-none-eabi-addr2line.exe oraz
C:\Program Files\CodeSourcery|\Sourcery
G++ Litelbin\arm-none-eabi-c+ +filt.exe.
Zatwierdzamy przyciskiem Apply i klikamy
OK (rysunek 9). Ostatnimi czynno$ciami
przed zbudowaniem naszego projektu bedzie
odznaczenie opcji automatycznego budowa-
nia projektu kliknieciem w menu Project
i odznaczenie Build Automatically (rysu-
nek 10) oraz odznaczenie opcji automatycz-
nego budowania projektu po jego wyczysz-
czenie, poprzez klikniecie w menu Project
-> Clean i oznaczajac opcje Start a build im-
mediately (rysunek 11). Teraz pozostaje nam
tylko klikniecie w menu Project -> Build All
lub naci$nigcie kombinacji klawiszy Ctrl+B.
Jezeli wszystko poszlo dobrze, to w zakladce
konsoli powinni$my uzyska¢ komunikat po-
dobny do tego z rysunku 12.
Wojciech Gelmuda
Katedra Elektroniki
Akademia Gorniczo-Hutnicza
gelmi@student.agh.edu.pl
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Innowacyjnos¢
w Twoim zasiegu

Altium Designer i Altium Nanoboard tworza
kompletne srodowisko projektowe. Oferujac
wszystko, co jest potrzebne do tatwego
tworzenia, testowania i optymalizagji
projektu na rzeczywistym sprzecie

i w rzeczywistym czasie. To unikalne potgczenie
zapewnia uzytkownikom innowacyjnos¢

i pozwala na projektowanie wyrdzniajgcych sie

produktow elektronicznych.
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